Skip to main content
Internet Archive's 25th Anniversary Logo

View Post [edit]

Poster: psubhashish Date: Feb 10, 2021 8:40pm
Forum: movies Subject: Closed Captioning does not display while playing video

I have recently started to upload my Creative Commons licensed documentary (https://archive.org/details/marginalized-aadhaar) on Archive.org. However, the Closed Captioning doesn't work despite naming it correctly (video is "2. MarginalizedAadhaar-closed-caption.mov" and srt is "2. MarginalizedAadhaar-closed-caption.en.srt" and "2. MarginalizedAadhaar-closed-caption.en.vtt". Can you please help with any fix?

Reply [edit]

Poster: Jeff Kaplan Date: Feb 11, 2021 12:13pm
Forum: movies Subject: Re: Closed Captioning does not display while playing video

it is fixed now. it is finicky. i removed the period and space after the number. i'd suggest avoiding spaces in file names.

Reply [edit]

Poster: psubhashish Date: Feb 12, 2021 3:21am
Forum: movies Subject: Re: Closed Captioning does not display while playing video

Thank you much, Jeff. I wish these tips are documented somewhere in the help page (unless they already are and I might have missed).

If I can ask one more question: how does the timecode link works (like this one for YouTube: https://www.youtube.com/watch?v=tBiPumGnVT4) on Archive? I have included the YouTube like timecode in the description but not sure how to make it work. As the documentary is long it would be a great help to the viewers to have links to the chapters inside the film. Thanks again and thanks in advance.

Reply [edit]

Poster: Jeff Kaplan Date: Feb 12, 2021 8:57am
Forum: movies Subject: Re: Closed Captioning does not display while playing video

you can link in to a start time using seconds like this:

2:38 Aadhaar and exclusion would have this link:
https://archive.org/details/marginalized-aadhaar/2-MarginalizedAadhaar-closed-caption.mov?start=158